CentOS/RHEL5 does not detect some onboard network cards +Videos

Sys Administration

CentOS's kernel is a very old kernel comparing to many other distributions. The reason is stability but some times it gets annoying.

For example today i wanted to upgrade CentOS 5.2 server at work to 5.3. to make this process as trouble free as possible i cloned the server into another computer but once it booted , i noticed that it doesn't detect new computer's on-board network card! and it was almost impossible to do the upgrade without Internet.

I tried to install its RHEL5 compatible drivers but non worked. so i decided to download and install the latest Linux kernel which was New kernel can detect this device out of the box which was exactly what i wanted. I did it and it worked perfectly well :).

Here is the script i wrote for compiling the kernel :

cd /usr/src
wget -c http://www.kernel.org/pub/linux/kernel/v2.6/linux-
tar xvfj linux-
cd /usr/src/linux-
make clean && make mrproper
make xconfig
make clean
make bzImage
make modules
make modules_install
make install
/sbin/mkinitrd /boot/initrd- 2.6.30

Video of the compiling process is attached, quality is very low however!

Your rating: None Average: 2.3 (6 votes)

You are missing some Flash content that should appear here! Perhaps your browser cannot display it, or maybe it did not initialize correctly.


Visitor's picture

How did you manage to

How did you manage to download the latest kernel if you network was not detected, hence no internet?